When a client has locked down security on workstations you may get the following error when processing an eConnect transaction:

DOC 68 ERROR: eConnect error - The source was not found, but some or all event logs could not be searched. To create the source, you need permission to read all event logs to make sure that the new source name is unique. Inaccessible logs: Security.

CAUTION IS ADVISED. Using the Registry Editor can have serious, potentially irreversible consequences. Windows Registry Editor and eConnect are Microsoft products. If you are unsure about the consequences of editing the registery in your particular circumstances, we strongly advise you to contact Microsoft or your Dynamics VAR for additional guidance.

A prerequisite to this answer is to make sure that eConnect is installed on the machine that Accountlink is installed on.  This is required for Accountlink to function and will result in the same error message as above.  To verify that eConnect is installed there should be an eConnect service in the services.msc control panel.  If it is not there, install eConnect and try a sync again.

Here is a screenshot that shows the eConnect service:

If the error persists after installing eConnect, or eConnect was already installed, you will need to assign the eConnect user permissions to the logs listed in the error after "Inaccessible logs".  There may be more logs than just Security that is listed.  If there is more, or a different one, you need to do the same steps for all logs listed.  For this walkthrough we will assume the only log is "Security".  Replace "Security" with whatever log you need to give permissions to.

The following steps assume you are logged into the machine as a user with Administrative permissions.

  1. Determine who the eConnect service account user is by looking at the "Log On As" column in services.msc.  In the screenshot above, this is the local "administrator" user.

  2. Check that this user is in the local system Administrators group.  If they are not, add them and attempt the sync again.
    - If the sync now works, congratulations! You can stop here.
    - If the sync still does not work with the same error message, continue below.

  3. Click Start, click Run, type regedit in the Open box, and then click OK. The Registry Editor window appears.

  4. Locate the following registry subkey:  
  5. Right-click Eventlog, and then click Permissions.
  6. The Permissions for Eventlog dialog box appears.
  7. Click Add
  8. Add the eConnect account and set the following permissions: “Full Control”
  9. Select OK
  10. Do the same for the Security sub key:  
  11. The Permissions for Security dialog box appears.
  12. Click Add
  13. Add the eConnect account and set the following permissions: “Full Control”
  14. Select <OK>